Recentemente troquei meu computador (note) por uma versão mais nova, com o Win Vista, hummm… No começo foi dureza, muita pesquisa e ajuste para que pudesse começar a trabalhar pra valer. Abaixo segue uma das minhas experiências mais chatas com o vista.

Após várias tentativas de colocar o Apache rodando no vista, corri atrás de informações na WEB e encotrei um passo a passo do “Simom Whatley” que foi bastante útil para mim. Clique no link abaixo para abrir o artigo dele; abaixo vou traduzir o processo, que na verdade é simples, mas tem que ser seguido à risca.

  1. Desinstalte qualquer instalação prévia do Apache  (Painel de Controle > Programas e Recursos).
    Certifique-se de remover qualquer pasta do Apache (veja em C:\Program Files\Apache Software Foundation\…).
  2. Desligue o Firewall via Painel de Controle
  3. Interrompa o Controle de Contas de Usuários (UAC).
  4. Obtenha a versão mais recente do Apache de http://httpd.apache.org/ e salve numa pasta qualquer do seu computador. Normalmente o arquivo vem com um nome comprido; bem como apache_2.2.4-win32-x86-no_ssl.msi, porêm para ficar mais fácil, você pode renomear simplesmente para  apache.msi.
  5. Iniciar > Todos os Programas > Accessorios Botão direito Command Prompt e escolha Executar como Administrador.
  6. Via prompt de comando vá até a pasta (Ex.: cd\download) onde gravou o arquivo de instalação do Apache (apache.msi).
  7. Digite em seguida “msiexec /i apache.msi” no prompt.
  8. Na tela “server information”;
    Network Domain: localhost
    Server Name: localhost
    Administrator E-mail Address: seu email..
  9. Escolha ainda nessa tela a opção “for All users on port 80″
  10. Eu uso como um servidor de desenvolvimento; por isso a minha configuração de dominio é “localhost”.
  11. Reinicialize o seu computador.
  12. Digite “http://localhost” a resposta no browser deverá ser algo como “It Works!”; caso não funcione de primeira não se desespere; acesse a opção “Iniciar\Todos os Programas\Apache HTTP server 2.2\Configure Apache server\Test Configuration” leia as informações ali e veja o que saiu errado.
  13. Não se esqueça de ativar o seu Firewall novamente. Ative também o UAC.

Link: Instalando o Apache no Vista

Essas dicas funcionaram bem para mim; espero que tenha evitado que alguns mais apressados devolvam o Windows Vista antes de quebrar a cabeça um pouco…rsrsrs.

Posts Relacionados

Tags: ,



3 Comentários

  • At 2009.07.05 21:30, Marco said:

    Valeu Caio..
    Realmente vc evitou que eu devolvesse o Vista.. ehehe
    abraço!

    • At 2009.10.09 13:36, Altair said:

      Foi tiro e queda. Funcionou perfeitamente no meu Vista Home Premium. Muitíssimo obrigado Caio.

      • At 2010.01.05 16:20, diogo moreira said:

        bem.ja tava farto de querer o apache e a porcaria do vista nao dar :D
        agora funciona.. obrigado

        You must be logged in to post a comment.